现在的位置: 首页Linux>正文
CentOS 5.7 Missing Dependency :kernel-header
2012年10月08日 Linux 评论关闭 ⁄ 被围观 4,857 次+

centos 5.7 yum时出现Missing Dependency :kernel-header 的解决方法,在此记下

错误信息如下:

  1. glibc-headers-2.5-81.el5_8.2.x86_64 from updates has depsolving problems   
  2. --> Missing Dependency: kernel-headers >= 2.2.1 is needed by package glibc-headers-2.5-81.el5_8.2.x86_64 (updates)   
  3. glibc-headers-2.5-81.el5_8.2.x86_64 from updates has depsolving problems   
  4. --> Missing Dependency: kernel-headers is needed by package glibc-headers-2.5-81.el5_8.2.x86_64 (updates)   
  5. Error: Missing Dependency: kernel-headers is needed by package glibc-headers-2.5-81.el5_8.2.x86_64 (updates)   
  6. Error: Missing Dependency: kernel-headers >= 2.2.1 is needed by package glibc-headers-2.5-81.el5_8.2.x86_64 (updates)   
  7.         You could try using --skip-broken to work around the problem   
  8.         You could try running: package-cleanup --problems   
  9.         package-cleanup --dupes   
  10.         rpm -Va --nofiles --nodigest  

安装kernel-headers即可解决问题,如下

  1. wget http://vault.centos.org/5.7/os/x86_64/centos/kernel-headers-2.6.18-274.el5.x86_64.rpm   
  2. rpm -ivh kernel-headers-2.6.18-274.el5.x86_64.rpm  
本文地址:http://www.92csz.com/00/1205.html
如非注明则为本站原创文章,欢迎转载。转载请注明转载自:moon's blog
 

抱歉!评论已关闭.